EasyApache 4

Currently Installed Packages

1 Recommendation
Contains Apache 2.4, PHP 7.2, PHP 7.3, PHP 7.4, and Ruby 2.7
Required.
  • Profile name is required.
Enter the filename without an extension. The system automatically adds the JSON extension.
Required. Filename cannot be “.” or “..”. Filename cannot include the following characters: / and NUL
  • Filename is required.
An optional description field to describe what this profile is about.
You can add multiple comma-separated (,) tags.

Recommendations for “PHP 7.2”: EOL Version *

This version has reached EOL. Learn More

  • We strongly recommend that you use a version that is still supported upstream. Learn More
  • If you do continue to use it, you will be susceptible to any remaining bugs or security issues. Learn More
*These recommendations appear because you have “ea-php72” installed on your system.

Available Profiles

Browse You must upload your profile as a “.json” file. The file must contain a name and at least one package. Learn more on How to create a Profile.
  • You must upload your profile as a “.json” file.
  • You must upload your profile as a “.json” file.
  • You cannot upload an empty file.
  • The file must contain a name and at least one package.
  • Invalid JSON.
  • Filename cannot include the following characters: / and NUL

Click Provision to install packages in a profile. Click Customize to use a profile as template and add or remove packages. For more information about profiles read EasyApache 4 - Create a Profile.

All PHP Options + OpCache cpanel
Contains All PHP Opts, Apache 2.4, PHP 7.4, PHP 8.0, and PHP 8.1
Download
This profile includes the following packages that are not supported on this server:
The system will not install the unsupported packages. Do you wish to continue?
Cancel
All PHP Options + ZendGuard cpanel
Contains All PHP Opts, Apache 2.4, PHP 7.4, PHP 8.0, and PHP 8.1
Download
This profile includes the following packages that are not supported on this server:
The system will not install the unsupported packages. Do you wish to continue?
Cancel
cPanel Default NGINX® cpanel
Contains NGINX® 1.21, Apache 2.4, PHP 7.4, and PHP 8.0
Download
This profile includes the following packages that are not supported on this server:
The system will not install the unsupported packages. Do you wish to continue?
Cancel
cPanel Default cpanel
Contains Apache 2.4, PHP 7.4, and PHP 8.0
Download
This profile includes the following packages that are not supported on this server:
The system will not install the unsupported packages. Do you wish to continue?
Cancel
cPanel Default + MPM ITK cpanel
Contains Apache 2.4, PHP 8.0, and MPM ITK
Download
This profile includes the following packages that are not supported on this server:
The system will not install the unsupported packages. Do you wish to continue?
Cancel
No PHP cpanel
Contains Apache 2.4 and No PHP
Download
This profile includes the following packages that are not supported on this server:
The system will not install the unsupported packages. Do you wish to continue?
Cancel
Ruby via mod_passenger cpanel
Contains Apache 2.4, Ruby 2.7, Passenger 6.0.7, and Node.js 10.15
Download
This profile includes the following packages that are not supported on this server:
The system will not install the unsupported packages. Do you wish to continue?
Cancel
cPanel Worker MPM cpanel
Contains Apache 2.4 and PHP 8.0
Download
This profile includes the following packages that are not supported on this server:
The system will not install the unsupported packages. Do you wish to continue?
Cancel

Share your opinion.

Thank you for choosing us! Since 1997, cPanel & WHM has helped customers from around the world.

We want to continue delivering a great experience. Please share your thoughts with us.

Start 90 Second Survey